Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Voliax
New Contributor

One Computer Gets Wrong IP and cannot connect

Hello i am kinda new user and trying to solve a problem.

On my configuration every computer gets 192.168.2.xxx and works fine. I am just connecting the cable all fine.

but 1 laptop is getting automatically 169.254.xxx.xxx like this address and cannot connect to the internet.

*I made a reservation for it`s mac address and assigned it an ip address but it`s not working too.

*Deleting it from device defination and connecting again same thing happens.

*i tried to configure its ip address manually still cannot connect to the internet and network.

 

I can`t solve this problem, i need help thank you.

 

3 REPLIES 3
ede_pfau
Esteemed Contributor III

When you configured the IP address manually, did you set the default gateway (and DNS) as well? Without gw you cannot access the internet.

My guess for the DHCP not working is that either the reserved address is already in use or already reserved, or that the MAC address is incorrect.

You could easily sniff the traffic when this PC is connected to really see what happens - DHCP is UDP ports 67 and 68.

"diag debug enable | diag sniffer packet internal 'udp and (port 67 or port 68)' 6" in the CLI.


Ede

"Kernel panic: Aiee, killing interrupt handler!"
Sparta_FTNT

For basic connectivity troubleshooting please follow below KB article.

 

http://kb.fortinet.com/kb...amp;externalId=FD30038

Voliax

Thanks for the answer!

I checked mac address and ip address both true. I also used reserved and free ip address`s too.