Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
VusalR
New Contributor

OSPF default route

Hi, 

 

i have 2 vdom, and i configured ospf between the vdom. on first vdom i configured sdwan and set the options remove static route when link goes down. also i select the option default route inject on the ospf. when link goes down static route remove routing table on first vdom, but second vdom can not remove old static route from its routing tables. although i config ospf between the vdoms. ospf is work.

 

I mean that, when on vdom 1 remove static route due to performance sla, at the same time vdom 2 and vdom 3 can remove static route.

8 REPLIES 8
Toshi_Esumi
Esteemed Contributor II

You shouldn't have static routes at vdom2 and vdom3. They should learn all routes from vdom1 over ospf.

VusalR

i understand, but i want to when vdom 1 remove default route from its routing table, at the same time vdom 2 and vdom3 update its routing tables,i mean that also vdom2 and vdom3 can remove default route, but when i check vdom2 and vdom3 routing tables i see 0.0.0.0 learn from vdom 1. but vdom 1 removed default route due to performance sla ( update static route options )

VusalR
New Contributor

+

Toshi_Esumi
Esteemed Contributor II

Did you set "set default-information-originate always" at vdom1? If "enable" instead, it shouldn't advertise the default route when it's not in routing-table.

VusalR

yes i have enabled, but again other vdoms know default route from vdom1 (OSPF)

Toshi_Esumi
Esteemed Contributor II

I would open a ticket with TAC.

VusalR
New Contributor

the problem was solved. although i enable default route inject command from gui, support told me i enabled again from cli with:

 

config router ospf set default-information-originate enable end

 

thanks a lot

Toshi_Esumi
Esteemed Contributor II

Routing protocol is something you can't configure effectively through FGT GUI. You have to learn it in CLI. The GUI's enable config must have made the default originate "always".