Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
kiclee
New Contributor II

It shows Return code -8 with error message when I input source-IP on syslog configuration.

Hello,   I  use Fortigate 800C with 5.0 version. I set syslog configurations on CLI. But I got failed error message that it shows Return code -8 when I command set source-ip x.x.x.x.   Why does it happen? Could you let me know how i should do to resolve it?   Thanks and Regards, Kiclee
3 REPLIES 3
Toshi_Esumi
Esteemed Contributor II

Doesn't look like source-ip is supported with 5.0. Below is from 5.0 logging handbook:

 

Enter the following commands:   config log syslogd setting     set csv {disable | enable}     set facility <facility_name>     set port <port_integer>     set reliable {disable | enable}     set server <ip_address>     set status {disable | enable}   end
kiclee
New Contributor II

Thanks a lot Toshi Esumi.

 

Please look at below,

 

FW1 # config log syslogd setting FW1 (setting) # set status Enable/disable remote syslog logging. *server Address of remote syslog server. reliable Enable/disable reliable logging (RFC3195). port Server listen port. csv Enable/disable CSV formatting of logs. facility Remote syslog facility. source-ip Source IP address of syslog. As it shows, there is value of setting source-ip.

 

 

 

Toshi_Esumi
Esteemed Contributor II

What does the line above "Command fail. Return code -8" actually says? It regularly gives some idea what it didn't like. But either

a) the IP you put in is not a valid one

b) a software bug

c) command option menu error (I've seen a long time ago that the option actually doesn't exist when it showed after hitting '?'.

In either case you need to update fortiOS much more modern one. 5.0 is three generations older than the last major version for 800C, which is 5.6.