Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
raphael_lage
New Contributor

HTTPS server certificate not enable

Hello everyone. I want to set up GUI access in my Fortigates to use SSL certificate (HTTPS). In my homologation firewall using OS version 6.4.7 the HTTPS server certificate option is available for me to choose the certificate I want to use. But in my two production firewalls that use OS version 6.4.2 this option is not available. My question is whether this option is only available in version 6.4.7, if yes, would you have any way to configure GUI access to use HTTPS otherwise?

3 REPLIES 3
Vichu_94
Staff
Staff

The SSL/HTTPS certificate could also be mapped from the CLI by the following command:

config system global
set auth-cert <Certificate Name >
end


Vishal P
sjoshi
Staff
Staff

Hi Raphael,

 

As per your request I have checked on v6.4.2 in GUI and HTTPS server certificate is present in the GUI. I have attached the Snapshot for it.

Go to System> Settings>HTTPS server certificate

 

 

 

Salon Raj Joshi
Markus_M
Staff
Staff

Hi Raphael,

 

it will be available on all FortiGate versions, I can speak only from 5.2 and newer.

On CLI you will be able to see/set it here:

config system global
   set admin-server-cert "mywebservercert"
end

 

On GUI, lacking the description, it is supposed to be here:

GUI > System (on global VDOM, if you have VDOMs) > Settings

And there "HTTPS server certificate"

If there is no "Settings", you are in a VDOM, you will have to switch to global.

An indicator, at least for me, whether I am in the VDOM is on the browser address bar, it says vdom=<vdomname>, for example
https:/....
/ng/firewall/policy/policy/standard?vdom=root

 

Best regards,

 

Markus