Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
sridharsre
New Contributor II

Getting error while trying to Retrieve the Config from FortiGate to FortiManager

Hi All,

Getting error while trying to Retrieve the Config from FortiGate to FortiManager.

 

"Failed to reload configuration. 'datasrc invalid. object: webfilter profile ftgd-wf filters category. detail: 32. solution: data not exist"

 

Please help me !!!

 

Regards,

Sridhar S

 

 

Warmest Regards, Sri Sre
7 REPLIES 7
lkorbasiewicz_FTNT

Hi,

 

This error is due to invalid webfilter category that should not exist in FortiOS 5.x

Look in the FortiGate config for something like: conf webfilter profile edit profile_name conf ftgd-wf conf filters (...) edit 32 set category 32 set action warning next (...) end So whenever you find "set category 32" under webfilter profile, you should delete it.

 

Best Regards,

Lukasz Korbasiewicz

Fortinet EMEA TAC Level 2

Fortinet NSE7 Certified

To reach support on call:

http://www.fortinet.com/support/contact_support.html

 

Helpful links:

http://kb.fortinet.com

http://video.fortinet.com

http://docs.fortinet.com

Lukasz Korbasiewicz,

Fortinet TAC Support

sridharsre

Hi Lukasz,

 

Thanks for the update !!!

 

I have only the default profile and it does not have 32 in it. When I entered edit 32, it just created one ?

 

Should I continue with this or I did something wrong ?

 

Regards,

Sridhar S

Warmest Regards, Sri Sre
sridharsre

when you say   "So whenever you find "set category 32" under webfilter profile, you should delete it." you mean this is not good for environment ?

 

Warmest Regards, Sri Sre
lkorbasiewicz_FTNT

Hi Sridhar,

 

Please go to:

config webfilter profile
edit profile_name
config ftgd-wf
config filters
show

 

After "show" command you will see some output. Search for "set category 32" - it does not have to be under "edit 32" - it may have another number. You should delete it and then retrieve the config. No need to remove from FortiManager - retrieve button in "revision history" will do the thing.

 

Best Regards,

Lukasz Korbasiewicz

Fortinet EMEA TAC Level 2

Fortinet NSE7 Certified

To reach support on call:

http://www.fortinet.com/support/contact_support.html

 

Helpful links:

http://kb.fortinet.com

http://video.fortinet.com

http://docs.fortinet.com

Lukasz Korbasiewicz,

Fortinet TAC Support

sridharsre

Hi Lukasz,

 

that worked !!! thanks a million !!!

 

Regards,

Sridhar S

Warmest Regards, Sri Sre
rahul9968
New Contributor

hi,

 

same problem with me. 

HaTiMuX
New Contributor III

Hello,

 

I had the same issue and after deleting "category 32" the retrieve worked fine. 

Thanks a lot.