Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Webig
New Contributor

Fortinet connect with several former pptp servers

Hello, I need to connect my fortinet 60d constantly with multiple servers PPTP VPN old. What do I need to set this up?

 

PPTP 1 172.1.X.X/16

PPTP 2 172.2.X.X/16

I have my fortinet link to router 192.168.1.X with wan1 interface, and with interface internal i have another network 192.168.100.x. I want that from this range can access to all PTP VPN.

 

This is the process that I do, I create a new Virtual lan with this options:

set vdom "root"
set pptp-client enable
set defaultgw disable
set dns-server-override disable
set interface "lan"
set vlanid 1
set pptp-user USER
set pptp-password PASSWORD

set pptp-server-ip IP
set pptp-auth-type auto

 

really should enable mode dhcp? for pptp server assign an ip virtual of range 172.1.X.X/16? But if i active mode dhcp de pptp-client set disabled automatically. I am very new to networking, excuse me

 

Thanks in advanced

8 REPLIES 8
ede_pfau
Esteemed Contributor III

I haven't used the PPTP client feature yet but in my opinion you can only have one PPTP client config per VDOM. That would mean you'd have to create multiple VDOMs to access multiple PPTP servers, and link them together via inter-VDOM links.


Ede

"Kernel panic: Aiee, killing interrupt handler!"
Webig
New Contributor

Thanks for your response. I create a Virtual Domain to test only for 1 pptp. After I add interface with commands and configure as first post. PPtp-client enable, vdom Pptp1... set interface ¿lan or wan? I have already created the virtual domain, but now does nothing, the pptp is not connected,do not get an ip. Really the mode is static, but if I put mode dhcp then the pptp-client disable auto. I'm lost not know how to do this :(

ede_pfau
Esteemed Contributor III

Why don't you try to configure the PPTP client in the real FGT first? VDOMs require inter-VDOM links and routing etc.


Ede

"Kernel panic: Aiee, killing interrupt handler!"
Webig
New Contributor

Is what I did the first time, the configuration that I know of pptp-client is only via commands creating a new interface into unique domain, root.

But I do not achieve it work, not know if I have to put static ip interface or this gets automatically one when connected or if I have to create a route or in the firewall policy

Webig
New Contributor

nobody can help me? thanks in advanced

Jeff_FTNT

From your setting, it should get IP, but will not install routes because of  (set defaultgw disable).

So change to default setting "set defaultgw enable/set dns-server-override enable"

Try to enable PPP debug to see what  happen.

dia debug  application  ppp -1

 

pptp client mode is not works with DHCP/PPPoE mode, only works in "static " mode.

 

Thanks.

RobertoP

I have the same problem as Webig. I understand that PPTP is not the safest, but I do not understand that Fortinet does not have a tutorial for this usual type of connection ...

Anybody cant help us?

I have solved the problem with a DLINK DFL800... How do I solve also with a Fortigate 60D?

Jeff_FTNT

Hi RobertoP,

You may share your setting and debug message (dia debug application ppp -1 ).Thanks