Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
tarunnurat
New Contributor

Forticlient can't connect to VPN on M1 Macbook Air

Hi,

 

I have a macbook with an M1 chip and can't get Forticlient v7 to work. I have tried v6 as well. My coworker with an Intel Macbook has Forticlient v6 running perfectly and can connect to our VPN with no issues. Going through the logs, I see the following errors.

Support/Fortinet/FortiClient/conf/epctrl.plist" not exist
20211129 12:30:27 [FortiTray:INFO] VpnManager.swift:611 VPN connecting
20211129 12:30:27 [FortiTray:INFO] VpnManager.swift:670 VPN disconnecting
20211129 12:30:27 [FortiTray:INFO] VpnManager.swift:591 VPN disconnected because of error: Tunnel error: startTunnelFailed

 Anyone has any idea about this? And has anyone with an M1 macbook managed to use Forticlient successfully to connect to their VPN? I can attach logs if needed.

Thanks!

10 REPLIES 10
be_fg
New Contributor II

Hi,

 

I've seen some issues in the past where FortiClient on latest MacOS isn't working as long as you are using a FQDN (vpn.exmaple.com) for the remote gateway within FortiClient VPN-Config.

As soon as you use the direct IP for the remote gateway, it works immediately.

Maybe this is worth another try to narrow down the problem further

________________________________________________
"Many hands make light work."
tarunnurat

You're right, it doesn't even connect with FQDN. However, I'm getting this problem after using the direct IP.

MorkfromOrk
New Contributor II

My boss has exactly the same problemwith Macbook Pro M1 and V7 Forticlient

No solution found

tarunnurat

Well, good to know I'm not alone. Is there any way we can get anyone's attention on this forum to look into this?

MorkfromOrk

We solved yesterday by simply allowing FortiTray in the General Tab of Security & Privacy as described in this link https://docs.fortinet.com/document/forticlient/7.0.1/macos-release-notes/223986/special-notices

 

tarunnurat

Thanks, I've tried doing this, but I'm not getting prompted to allow FortiTray in the General Tab of Security & Privacy. I've opened Forticlient, but it does not prompt me for allowing FortiTray. At what point did that prompt happen for you?

MorkfromOrk

No any prompt, in the general tab we have just found the same message of the picture below that the "fortitray was blocked" (bottom message) and we clicked on allow button then we tried again to start forticlient and now it was working

c2268f3508edeb126d265a84d6d146ce_FortiTray

tarunnurat

Hmm, I see. When did you see this message in the General tab hough? I don't get this message. Did it come up when you opened Forticlient console?

dh12

Hi, 

Did you ever find a solution to this? I am currently having the same troubles. I have allowed forticlient full disc access like in the special notes and still not working. I also did not recieve that notification in the general tab like the screen shot shows above. Very frustrating!