Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
rdoshi2511
New Contributor

Forticlient VPN 7.0.5 Blank Screen with macOS Mojave

Dear All

 

Off lately the forticlient stopped working and shows blank screen on start.

I have uninstalled and reinstalled it many times with different versions but it all behaves the same.

 

Below is screenshot.

 

Screen Shot 2022-06-30 at 2.43.18 PM.png

 

I even followed instructions in the below link

 

https://docs.fortinet.com/document/forticlient/7.0.5/macos-release-notes/223986/special-notices

 

but a few files are not available in my version.

 

Below is the screenshot from the Security & Privacy

 

Screen Shot 2022-06-30 at 2.45.17 PM.png

 

Screen Shot 2022-06-30 at 2.45.41 PM.png

 

Please help.

26 REPLIES 26
btan

No, you do not have to.

Only fctservctl & FortiClient is required.

fmon is for Antivirus feature, fcaptmon is for sandbox

Both are paid-version feature.

Regards,
Bon
rdoshi2511

@btan 

Is there a way we can connecct remotely to check the issue..maybe you might be able to find something which i am missing

rdoshi2511

@btan 

If i directly try to restore a vpn conf file and try to connect, it gives error

 

The VPN connection terminates unexpectedly! (Error Code: -113)

 

 

rdoshi2511

@btan 
on version 7.0.5 i found one issue
when i run the fcconfig directly in terminal to generate a config file i get below error

2022-07-05 15:35:01.048 fcconfig[5996:101989] Failed to register with the provider: Couldn’t communicate with a helper application.

This could be the issue why its not working on macOS Mojave. Do you have any clue?

btan

Hi rdoshi2511,

 

Error Code: -113 is very broad and mostly need to run debug on FortiGate side to find out what happened.

"helper application" related error should have fixed from FCT 6.4.4 onwards.

We are looking at macOS Monterey 12, not sure why you keep mentioning Mojave 10.

>Is other devices in same OS using this FCT 6.4.8 working fine?
I suspect there is something wrong with your this particular macbook.

Regards,
Bon
rdoshi2511

@btan Yes I am running macOS Monterey 12.4

I even tried the latest release 7.0.6. Still the issue is the same.

 

Not sure how to troubleshoot the error since no error log is generated.

drsax
New Contributor

Hi,

can you share again the download link as I don't have a customer protection plan?

Cheers