Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
rdoshi2511
New Contributor

Forticlient VPN 7.0.5 Blank Screen with macOS Mojave

Dear All

 

Off lately the forticlient stopped working and shows blank screen on start.

I have uninstalled and reinstalled it many times with different versions but it all behaves the same.

 

Below is screenshot.

 

Screen Shot 2022-06-30 at 2.43.18 PM.png

 

I even followed instructions in the below link

 

https://docs.fortinet.com/document/forticlient/7.0.5/macos-release-notes/223986/special-notices

 

but a few files are not available in my version.

 

Below is the screenshot from the Security & Privacy

 

Screen Shot 2022-06-30 at 2.45.17 PM.png

 

Screen Shot 2022-06-30 at 2.45.41 PM.png

 

Please help.

26 REPLIES 26
btan

FCT 6.4.8 free version macOS can be found here:
https://support.fortinet.com/Download/FirmwareImages.aspx

FortiClientMacv6.006.46.4.8/

 

Or download it below, link available for a month:

https://fortinet.egnyte.com/dl/j2hXrkhaWm

Password: fBw2JhiY

 

 

Regards,
Bon
rdoshi2511

@btan I am able to install the version shared by yourself. But the problem with Forticlient VPN 6.4.x version with macOS Mojave is that it doesnt save any configuration. Are there any post installation steps that i need to perform post the installation.

 

 

btan

Hi rdoshi2511,

 

Do you mean it does not save your personal configured VPN settings?
I tested v6.4.8 with macOS 12 and it does save the config after a reboot.

Not sure if there is issue with 6.4.x with macOS Mojave.

Regards,
Bon
rdoshi2511

Dear @btan 

 

Yes with the v6.4.8 it doesnt let me save the configuration. After creating a new VPN connection and saving nothing actually happens.

I am running macOS Mojave 12.4. What version are you running?

Appreciate your help in solving the issue.
Regards,

Rak**bleep**

btan

I tested with macOS Monterey 12.4.

Do you mean you are using Mojave 10.14? It should be working, does it still behave the same after reboot?

Regards,
Bon
rdoshi2511

@btan 

No i meant macOS 12.4 only.


I am also on macOS Monterey 12.4.

 

See below issue of configuration not getting saved.

 

https://www.dropbox.com/s/ae6brz007h7krdd/Screen%20Recording%202022-07-04%20at%2010.48.02%20AM.mov?d...

 

 

btan

This is indeed weird. Not sure what's wrong with your Macbook.

Free version FCT does not come with any troubleshooting utilities, and issue is not reproducible on other machines. 

Is it possible that your device is already having other VPN client/virtual adapter?

Regards,
Bon
rdoshi2511

@btan 

Nopes i do not have any other vpn client. Yes the issue is pretty strange. Is there anything specifically you did in the folder access authorizations for this version or any particular write permission that should be given..Maybe that could help me look further down.

btan

Besides the one stated in https://docs.fortinet.com/document/forticlient/6.4.8/macos-release-notes/223986/special-notices
There isn't any special config needs to be done. Perhaps it's really out of luck if everything is done and the issue still persist.

Regards,
Bon
rdoshi2511

@btan I do not have any fmon/fmon2 files in the installation directory.

 You may have to manually add fmon2 to the list, as it may not be in the list of applications to allow full disk access to. Click the + icon to add an application. Browse to /Library/Application Support/Fortinet/FortiClient/bin/ and select fmon2.

 

Is this required??