Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Sebastiaan_Koopmans
Contributor II

Forticlient 5.6.1 and FortiEMS 1.2.2 is OUT!!

Forticlient 5.6.1 and EMS 1.2.2 is out...

We are going to upgrade tonight and will let you now the feedback

FortiAnalyzer / 6.4.0

FortiClient / 6.2.6 FortiClient EMS VM / 6.2.6

FortiGate 300D HA 6.2.4 FortiGate 500E HA 6.2.4 FortiGate 30E / 60E / 100E / 6.0.9 FortiMail VM HA / 6.4.0 FortiSandbox VM / 3.2.0

FortiWeb VM / 6.3.2

FortiManager VM / 6.4.0

7 Solutions
SteveG

Creating the 5.6.1 installer works, well it's listed and downloadable. However pushing the 5.6.1 install via EMS to a client PC broke FortiClient completely. The install ran but when the laptop rebooted FC had disappeared completely, looks like the uninstall of the previous client worked but the 5.6.1 install failed. So I rebooted the laptop and downloaded the 5.6.1 installer from the EMS server but when running it get "The installer has encountered an unexpected error installing this package". Now manually installing 5.4.4 build created by EMS. Once that's installed I'll reboot and try 5.6.1 again.

 

See attached screen grab.

 

View solution in original post

SteveG

I've just done the same! Ticket No. 2440807

View solution in original post

Jeroen_Nieuwenbroek

did the same here: ticket number 2440851 .  Rescheduled the installer to start at 11:50PM

JN

View solution in original post

Sebastiaan_Koopmans

Ticketnr: 2440804

 

Answer: 

This issue is already reported to our Engineering with BUG ID: 0458950, please for now keep on hold to upgrade the clients from EMS.
Will get back to you as soon as I get further information. 

FortiAnalyzer / 6.4.0

FortiClient / 6.2.6 FortiClient EMS VM / 6.2.6

FortiGate 300D HA 6.2.4 FortiGate 500E HA 6.2.4 FortiGate 30E / 60E / 100E / 6.0.9 FortiMail VM HA / 6.4.0 FortiSandbox VM / 3.2.0

FortiWeb VM / 6.3.2

FortiManager VM / 6.4.0

View solution in original post

Jeroen_Nieuwenbroek

[size="4"]For now, set the permission on the shared folder to avoid the clients to update.[/size]

(Deny read access for 'everybody' .)

JN

View solution in original post

neonbit

Yup it's a known bug, there's a customer support bulletin available explaining it, looks like the fix will be out in 5.6.2 due for release on Nov 13th.

 

Customer Support Bulletin CSB-171110-1 FortiClient 5.6.1 Installation Package Failure 2017-11-10 Subject: FortiClient 5.6.1 Installation Package Failure Released: 2017-11-10 Modified: 2017-11-10  Product: FortiClient 5.6.1

Description:

Upon creation of a FortiClient 5.6.1 installation package when created by the Enterprise Management Server (EMS), the package encounters an error.  The issue occurs if EMS downloads FortiClient 5.6.1 from the FortiGuard network.  When the error occurs, EMS displays the following message:

"The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2711.”

 

 

Possibly Affected Products:

FortiClient 5.6.1

 

Remedy:

FortClient 5.6.2 will correct this issue and will be released by 13th November

View solution in original post

RobertReynolds

my EMS just pushed out 5.6.2 to my endpoints

View solution in original post

40 REPLIES 40
tlwisner

I'll be testing the 5.6.2 rollout this morning.  I wish I has tested the 5.6.1 which just removed most of my clients.

Phuoc_Ngo

We upgrade to EMS 1.2.2 and Foriticlient version got upgrade to 5.6.2.  The issue we encounter is users does not have the option to enter their username and password under IPsec VPN tunnel. Support confirmed there is a known bug on EMS 1.2.2.  Anyone experience the same issue on IPsec VPN tunnel. 

Below is the support response and the bug number.

 

"we seen a bug 0439370 reported for not able to seeing username on Forticlient for ipsec connection as configuration sent through EMS."

 

 

midnightz

Phuoc Ngo wrote:

We upgrade to EMS 1.2.2 and Foriticlient version got upgrade to 5.6.2.  The issue we encounter is users does not have the option to enter their username and password under IPsec VPN tunnel. Support confirmed there is a known bug on EMS 1.2.2.  Anyone experience the same issue on IPsec VPN tunnel. 

Below is the support response and the bug number.

 

"we seen a bug 0439370 reported for not able to seeing username on Forticlient for ipsec connection as configuration sent through EMS."

 

 

Yep... there's always a "bug" that will break every VPN user when updating the EMS.  I had the same issue with the creds boxes missing.  You have to enable the xauth part in the vpn tunnel in your profile.  Under your profile that your pushing > VPN tab > vpn tunnels, edit tunnel > advanced settings > click enable XAuth.  

Jeroen_Nieuwenbroek

[size="4"]For now, set the permission on the shared folder to avoid the clients to update.[/size]

(Deny read access for 'everybody' .)

JN

Sebastiaan_Koopmans

We dont use the auto update function so for us no problem ..... only thing is that i cant use the latest 5.6.1 client if i want to install..... (offcource i can download the client from support page but then you dont have settings or specific features etc) and the forticonfigurator 5.6.1 is not available yet on FNDN so.... :( 

 

I Think support nows now that we have found an bug :)

FortiAnalyzer / 6.4.0

FortiClient / 6.2.6 FortiClient EMS VM / 6.2.6

FortiGate 300D HA 6.2.4 FortiGate 500E HA 6.2.4 FortiGate 30E / 60E / 100E / 6.0.9 FortiMail VM HA / 6.4.0 FortiSandbox VM / 3.2.0

FortiWeb VM / 6.3.2

FortiManager VM / 6.4.0

Jeroen_Nieuwenbroek

Upgrading from version 5.6.0 with FortiClientSetup_5.6.1_x64.exe gives me an error: The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2711.

 

Eventviewer gives a little hint:

Product: FortiClient -- The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2711. The arguments are: Feature_WanAcceleration, , (NULL) (NULL) (NULL) (NULL) (NULL) 7B35313539393333422D444339352D343246312D383233332D3042383246423441423534337D

 

History / Steps to reproduce

Today i received a message from EMS:  FortiClients (5.6.1, 5.6.1) are now available for deployment.

In my deployment folder I copied: FortiClientSetup_5.6.1_x64.exe to a test PC and started the installer.

 

OS Windows 7, EMS version 1.2.1.0394

JN

SteveG

Looks like a bug as there's a few of us with the same problem.

rcheesman
New Contributor

Where did you download it from?  We can only see the release notes.  The installer is not there to be downloaded.  Neither is 5.6.1.  I think they were both pulled.  Maybe due to all of the new bugs?

Sebastiaan_Koopmans

i checked it and indeed Forticlient 5.6.1 and EMS 1.2.2 is gone??¿¿ ..... i have him both :p

 

5.6.0 is still available instead...

FortiAnalyzer / 6.4.0

FortiClient / 6.2.6 FortiClient EMS VM / 6.2.6

FortiGate 300D HA 6.2.4 FortiGate 500E HA 6.2.4 FortiGate 30E / 60E / 100E / 6.0.9 FortiMail VM HA / 6.4.0 FortiSandbox VM / 3.2.0

FortiWeb VM / 6.3.2

FortiManager VM / 6.4.0

rcheesman

I have 1.2.1 and it has bugs.  I was hoping 1.2.2 would squash them.  I guess I have to wait again.