Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
dstromberg
New Contributor

FortiClient VPN on macOS host running VirtualBox with a Windows 10 guest hangs on auth

 

 

Hello.

 

I have the IPsec VPN working on the mac side, with no virtualization involved.

 

In the Windows 10 guest, FortiClient asks for my username and password, and then hangs.  It doesn't ask for my fortitoken number.

 

I tried configuring VirtualBox to use a "Bridged Adaptor" and "NAT", separately.  Testing with each failed both times.

 

I tried turning off "IKE and AuthIP IPsec Keyring Modules" and "FortiClient VPN Service Scheduler", separately, in mssconfig -> Services.  Neither helped with connecting to the VPN, but turning them both off did allow ike-scan (from chocolatey) to scan the FortiGate box from the Windows guest.

 

I'm not trying to do anything fancy with routing.  I just want both the macos and the windows to be able to use the IPsec VPN.

 

Versions of things:

FortiClient 7.0.0.0029

macOS 11.4

VirtualBox 6.1.24

Windows 10.0 build 19043

 

Any suggestions folks?

 

Thanks!

 

2 REPLIES 2
dstromberg
New Contributor

BTW, when I say "I tried configuring VirtualBox to use a 'Bridged Adaptor' and 'NAT', separately.  Testing with each failed both times.", I meant that FortiClient failed to connect in the Windows guest.

 

I'm now guessing that maybe I should just try to connect to a VPN-only network resource with NAT, without first trying to run FortiClient in it - with the idea in mind that perhaps it will share the mac's NAT connection.

 

 

dstromberg
New Contributor

 

I just tried disconnecting from the VPN on the macos side prior to attempting to connect to the VPN inside the Windows 10 VirtualBox; FortiClient still just hangs.