Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
JensG
New Contributor II

FortiAP - Apple Devices WiFi handoff issues

Hi,

 

I have issues with iPhones, iPads and MacBooks loosing WiFi connection when moving to another room.

The devices try to keep/establish the connection and it seems they are trying to change the AP but are not able to do so. They are switching between full WiFi power and just one dot in the WiFi sign.

Manually switching off WLAN in the devices and switching it on again after a while does not help.

When I reboot the device it connects immediately and all is fine until I move into another room. 

 

Handoff is switched on, both frequency and AP.

 

I am using FortiAP 231F and 23JF and FGT60F, all first with v6.4.7 and now v7.0.3, having AP versions respectively. No difference whether v6 or v7 is used.

 

The Apple devices are newer and older ones, and different models, all with OS versions up to date (iOS 15.1.1, iPadOS 15.1, macOS 12.0.1)

 

Has someone else seen similar issues?

Any ideas?

 

Thank you,

Jens

12 REPLIES 12
JensG
New Contributor II

After testing around a bit it seems, that at least my MacBook Pro is able to roam around in the building and gets a handoff from one AP to the other.

 

So, maybe it is not related to handoff?

JensG
New Contributor II

Is this possibly related to devices gone to kind of hibernation mode and then being activated in the area of a different AP? 

JensG
New Contributor II

I forgot to tell: I am using WPA 3 Transition with 2.4 GHz and 5 GHz for the WLAN.

fl3aflikr
New Contributor

I have similar issues between fortiap and fortiwifi.  In my office i connect to fortiap and when i move to the area with the fortiwifi, the ssid just disconnects.  I can connect manually to the fortiwifi.  If i drift away from the fortiap and return, i am still disconnected.  using updated iphone and it happens to others on an iphone as well.  i have read that roaming is a function of the client and see that others have issues on apple devices. but the cox panoramic wifi from before didnt have these issues with not reconnecting to the ssid when in range.

 

abitschine
New Contributor

Hello,
I also have this problem with iPhones, but only using WPA3 (SAE in my case). I have no problem using the same devices with WPA2.

JensG
New Contributor II

Hello @fl3aflikr & @abitschine , thanks for your response. Good to know I am not the only one with this issue. Has one of you contacted Fortinet Support regarding your issues? I have opened a ticket with them. 

 

I have another SSID with WPA2 only and there are no issues at all. Although I have to say, that I don‘t use any iPhones, iPads or MacBooks in that WPA2 WLAN.

abitschine

I have just created my WPA3 WLAN, and I am starting to investigate this issue. I didn't contact Fortinet support.

As for my WPA3 WLAN, I only have Apple devices that connect to it. I haven't had the opportunity to test with other manufacturers yet.

jkassner
New Contributor II

Same here,

 

often when the Apple Device roams, the TX Rate on the FGT (AP to Device) drops to 6 Mbit, which is not a ax Rate (SSID configured to ax/ac only WPA3).

 

FAP231F on 7.0.2.

 

Ticket with FTNT is open.

______________________________________________________
Have you tried turning diag deb off and on again :D
jkassner
New Contributor II

Hi Jens,

 

Roaming/Handoff works fine here with:

 

config wireless-controller vap

    edit „WIFI“

        set ssid „SSID“

        set security wpa3-sae-transition

        set pmf optional

        set mbo enable

        set voice-enterprise enable

        set neighbor-report-dual-band enable

        set fast-bss-transition enable

        set local-bridging enable

        set schedule "always"

        set qos-profile "WMM"

    next

end

 

but most of the time Apple devices will drop to 6 MBit/s TX Rate after roaming, which makes the connection unusable. (Enable TX Rate RX Rate in the Wifi Client Monitor and check)

 

81E on 7.0.3, 231F on 7.0.2

______________________________________________________
Have you tried turning diag deb off and on again :D