Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
DanieleS99
New Contributor III

Backup Problem with Automation Stitch

Hi,

I have a problem with a job backup by the Automation Stitch.

When i execute the backup by automation stitch i see this error:

 

"Connect to ftp server 192.168.50.50...

Error code 1: File not found

Send config file to tftp server via vdom root failed.

Command fail. Return code -1"

 

But if i copy and paste the command in the cli console, the backup work correctly.

Any idea?

 

Thanks

 

 

1 Solution
DanieleS99
New Contributor III

Thanks for the reply Alex, 

in the end I managed to understand the problem and it did not center partially with the fortigate.
In the sense that, our tftp server, for write rights, wants an empty file to be created first with the name of the file configuration.
Only, since the fortigates are clustered, when the backup is done, the fortigate job adds the serial number in the configuration file name plus the name of the file conf create.
Consequently the configuration name did not match the empty one on the tftp server.
Thanks again.

View solution in original post

2 REPLIES 2
AlexC-FTNT
Staff
Staff

If the commands are the same, the problem is likely with routing. 

Check that you can reach the ftp server over the correct interface from root vdom, or look in the routing table of the root vdom (this is the management vdom in your case, can't run on a different one):

get router info routing-table detail 192.168.50.50 


- Toss a 'Like' to your fixxer, oh Valley of Plenty! and chose the solution, too00oo -
DanieleS99
New Contributor III

Thanks for the reply Alex, 

in the end I managed to understand the problem and it did not center partially with the fortigate.
In the sense that, our tftp server, for write rights, wants an empty file to be created first with the name of the file configuration.
Only, since the fortigates are clustered, when the backup is done, the fortigate job adds the serial number in the configuration file name plus the name of the file conf create.
Consequently the configuration name did not match the empty one on the tftp server.
Thanks again.