FortiSOAR Knowledge Base
FortiSOAR: Security Orchestration and Response software provides innovative case management, automation, and orchestration. It pulls together all of an organization's tools, helps unify operations, and reduce alert fatigue, context switching, and the mean time to respond to incidents.
Andy_G
Staff
Staff
Article Id 198316
Description

Description:

Whenever user imports attachments or indicator module the file field of that module gets deleted after import.


Root Cause:

Issue occurs due to code defect responsible to import module using "Settings --> Configuration Manager".


Solution

Steps to Reproduce:


Export attachments module: 

a. Click on settings, on upper right corner

b. Go to “Configuration Manager” under “APPLICATION EDITOR” section

c. check Attachments module under “Export Configuration” tab.

d. Now click on “EXPORT CONFIGURATION” button highlighted in YELLOW. [REF] screenshot below

e. JSON file for the same will be created



Import attachments module: 

  • Repeat steps 'a' and 'b' mentioned above.
  • Select “Import Configuration” tab and drag the JSON file created.  [REF] screenshot below



  • this causes file field to disappear in ATTACHMENT MODULE


Fix:

We have fixed the issue in our  CyOPs™ 4.12.2 release.


Applicable Versions:

CyOPs™ 4.12.0 and 4.12.1


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