EMS server 7.4.5 - Internal Server Error
Hi,
We recently released two Linux VMs (Ubuntu 24.04 LTS) to configure the EMS server and external DB Postgres. The architecture is EMS with standalone remote DB without Docker (as reported on the Fortinet official document).
With this introduction, I'll explain that the problem we encountered occurred 10 days after completing the configuration.
Suddenly, the EMS GUI was no longer usable, displaying an error 500 (see image below). Both VMs, the one hosting the EMS and the one hosting the external DB, were correctly reachable via SSH.
As additional information, I'd like to point out that the EMS server and external DB are on the same network and there are no network devices in between them. Furthermore, the hardware resources of both VMs are oversized compared to Fortinet's minimum requirements, and during the error, we didn't detect any problems or resource spikes on the VMs (e.g., disk full or resource spikes).
Since the error persisted, we first attempted to restart the systems in this order: first the external DB, then the EMS server, but the situation remained the same.
Subsequently, following a Fortinet KB, we extracted the logs and attempted to restart the Apache process with this command:
"emscli service restart --name apache2", but even after this attempt, the 500 internal server error persisted.
While analyzing the extracted logs, we detected a message:
FATAL: server login has been failing, try again later (server_login_retry)
(SQLSTATE 08P01)
While we were investigating, some system administrators told us that the 500 error was due to an incorrect timezone and that a control script called tzlocal was run on the EMS server, which resolved the situation.
I'd like to know if anyone else has encountered this error and how you resolved it.
Thank you all in advance.
#EMS
