Skip to main content
ldsouza
Staff
Staff
July 22, 2025

Troubleshooting Tip: Error:'The REST API has invalid multipart form-data format' while configuring the SAML server

  • July 22, 2025
  • 0 replies
  • 399 views
Description This article describes how to resolve the error 'The REST API has invalid multipart form-data format' that may occur when setting up a SAML server through FortiWeb's graphical user interface (GUI).
Scope FortiWeb, FortiWeb-VM.
Solution

Starting with v7.6.2, it is not possible to successfully configure the SAML server if the uploaded metadata file name contains spaces or special characters. The system enforces stricter validation on multipart form-data, and such filenames will result in a REST API format error.

 

Unable to create SAML server.jpg

 

To fix the issue, rename the file to ensure that no spaces or special characters are included in the metadata file name.

 

successful upload.jpg

 

Related document:
Offloading HTTP authentication and authorization

Thought Leadership Security Summit. Outpace New Threats with AI - enhanced defense. Tuesday, Septmeber 15, 8:30 AM - 2:30 PM PT. The Golf Club at Newcastle, WA.
Virtual event | September 2026. SASE summit. The age of autonomous trust. Register here!