Technical Tip: FortiWeb shows error 'The interface name is too long' when attempting to create a VLAN subinterface in a link aggregation interface
Description | This article describes the circumstances behind the error 'The interface name is too long' that appears when attempting to create a VLAN interface inside a FortiWeb link aggregation interface. |
Scope | FortiWeb (physical devices). |
Solution | Normally, when a link aggregation is created, VLAN sub-interfaces must be configured inside this link aggregate. However, when a VLAN is being created, an error related to the VLAN's name extension may appear:
 ![]()  The same message is shown upon trying to create the VLAN interface using CLI commands:  ![]()  This happens even when attempting to use very short names (for example, with only 1 or 2 characters):  ![]()  This situation is expected behavior by design. This error message actually refers to the name of the parent interface (in this case, the name of the aggregation link interface), not the interface on which the VLAN is being created. For this reason, the parent interface name must be shorter than 15 characters.  As a workaround, delete the link aggregation interface and create a new one using a shorter name. After that, create the VLAN interfaces inside this new link aggregation interface.  ![]() Behavior from FortiWeb v8.0.5 and above versions: Related documentation: |




