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JordAnge
Staff
Staff
February 19, 2026

Troubleshooting Tip: Cannot download recorded calls in batch

  • February 19, 2026
  • 0 replies
  • 28 views
Description

This article describes how to resolve an issue where users cannot download audio files in batches (Monitor -> Storage -> Recorded Call).

Scope FortiVoice v7.0.2.
Solution

When using the Download All option, it generates a .tgz file which is empty with 0 bytes. No error message appears.

 

CallRecord_DownloadBatch01.png

 

CallRecord_DownloadBatch02.png

 

CallRecord_DownloadBatch03.PNG

 

Downloading the files one by one works as expected.

 

Even using a different web browser results in the same issue.

 

Root cause:

 

The dial_from value in the text file is used as part of the .wav file's name. When dial_from is missing, the resulting .wav file name starts with a hyphen, like '-XXXXXXXX'. During the subsequent packaging step, the program uses the Linux tar command, which encounters an error due to the file name starting with a hyphen.

 

A prefix was added to the file names to prevent this issue. Upgrade FortiVoice to v7.0.5 (Resolved issues) or 7.2.

 

Related document:
Call recording