Skip to main content
Contributor
April 10, 2020

Technical Note: CSTN 00014 - Notes when customer are unable to load API credentials from cache or DAS

  • April 10, 2020
  • 0 replies
  • 1952 views
Description

Issue:
Unable to load API credentials from cache or DAS.

The issue occurs when communication between at least two of the services is broken. The service is not able to authenticate itself as the appliance keys does not match. This tends to throw the error and the feature is not usable.


Root cause:

This issues occurs when the services' appliance keys does not match with the corresponding keys in authentication database.


Solution

Fix: To resolve this issue, perform the following steps:


1. Re-generate the keys using the command '/opt/cyops-auth/.env/bin/python /opt/cyops-auth/defaultappliance.py generate-appliance-keys'


2. And then restart all CyOPs services, using the following command:

   'csadm services --restart'


Found in Version:

5.0.0 and above