Skip to main content
nsoni
Staff
Staff
January 27, 2026

Troubleshooting Tip: Event Integrity validation for random event files remain 'Not validated' as validation fails with error 'fileValidationResponse: file not found' in backend logs

  • January 27, 2026
  • 0 replies
  • 112 views
Description The article provides troubleshooting steps for issues with event integrity validation for random event files that remain 'Not validated' in EventDB-based FortiSIEM deployment.
Scope FortiSIEM with EventDB (/data) as event storage.
Solution

Event integrity validation from ADMIN -> Settings -> Event Integrity shows 'Not validated' for random event files with 'fileValidationResponse: file not found' error in log file /opt/phoenix/log/phoenix.log as the event file actually does not exist in event storage (/data).

 

  1. Check for logs with the keyword CORRUPTED or UNABLE_CREATE_DIR in /opt/phoenix/log/phoenix.log:

 

grep -E 'CORRUPTED|UNABLE_CREATE_DIR' /opt/phoenix/log/phoenix.log

 

  1. Remove corrupted event files from /data based on the output from step 1:

 

rm <eventFilePath>

 

  1. Enforce ownership:

 

chown -R admin.admin /data/eventdb/

chown -R admin.admin /archive/

 

  1. Restart phDataManager on supervisor and worker nodes:

 

killall -9 phDataManager

Thought Leadership Security Summit. Outpace New Threats with AI - enhanced defense. Tuesday, Septmeber 15, 8:30 AM - 2:30 PM PT. The Golf Club at Newcastle, WA.
Virtual event | September 2026. SASE summit. The age of autonomous trust. Register here!