How to correctly re-register a Collector all ph procs are down.
! collector was registered at one point
lost the password
updated password then tried to run phtools start all
prcos are down and will not come up.
/opt/phoenix/bin/phProvisionCollector --add admin 'biglong pw' siem vendor org
Continuing to provision the Collector
Failed to register collector!
Cause:
The organization "130862006-vendor" has already registered a collector with name "collector name"
(But we had to change the credentials)
Do these procedures still apply to re-register a collector? after getting the above error , all their ph procs are down.
:1. SSH to FortiSIEM Supervisor
2. Enter the following command to login into PSQL: #psql -U phoenix phoenixdb
3. Update the PSQL Database: =>ph_sys_collector set natural_id='' where name=<collector name>;
4. Quit PSQL: =>\q
5. Re-register the Collector to Supervisor. Find in the related articles bellow "How to register a Collector or Super". Revised:
In step 3 full synxax => update ph_sys_collector set natural_id = '' where name = 'collector name'
phtools --start all
[PH_MODULE_LOCAL_CONFIG_LOADED]:[eventSeverity]=PHL_INFO,[procName]=phtools,[fileName]=phConfigLoader.cpp,[lineNumber]=168,[configName]=global,[phLogDetail]=Module loaded local config successfully
[PH_LICENSE_ERROR]:[eventSeverity]=PHL_ERROR,[procName]=phtools,[fileName]=phInstalledLicense.cpp,[lineNumber]=170,[errorString]=License Error: Please request new license from support, thanks!,[phLogDetail]=License error, please contact support.
Is it a License issue? Do we investigate the phoenix log?
