Troubleshooting Tip: Recover FortiPortal after the cluster is down
| Description | This article describes how to turn on a FortiPortal cluster when all of the nodes are shut down. |
| Scope | FortiPortal. |
| Solution | Due to some environment migration or maintenance tasks, it may be necessary to turn off the FortiPortal cluster.
When working with a FortiPortal cluster, be aware of some technical considerations, as described in in Limitations with Scalable Cluster - FortiPortal release notes.
Initiating only the primary instance may cause some additional issues which affect the functionality of the cluster:
[fortiportal.utils.redis:redis.py:39 wrapper()] - WARNING - Fail to Execute Redis Query Because of No master found for 'mymaster'.
After a cluster is fully down, all three nodes need to be brought up at the same time.
|
