Troubleshooting Tip: Unable to validate credentials on Cisco SG series switch
| Description | This article describes how to troubleshoot an issue where credential validation fails on a Cisco SG switch. |
| Scope | FortiNAC, SG3, SG300, SF300. |
| Solution | 1) Verify the SSH Server setting 'SSH User Authentication by Password' on the switch is disabled. Run the following SNMP walk from the appliance CLI:
The output of the command should provide an Integer value showing if the service is enabled or disabled.
Integer= 1 --> enabled
2) If snmpwalk returns a '1' (enabled), disable the 'SSH User Authentication by Password' setting on the switch.
The setting can also be disabled directly from FortiNAC with the following CLI command:
snmpset -v1 -c <community> <ipaddress> 1.3.6.1.4.1.9.6.1.101.78.2.108.0 i 2
To enable it again :
snmpset -v1 -c <community> <ipaddress> 1.3.6.1.4.1.9.6.1.101.78.2.108.0 i 1
3) Additional settings that can be configured directly through SG switch CLI:
no ip ssh password-auth
4) If there is still CLI credential validation error then test by removing the enable password in the Switch Credential configuration tab in FortiNAC. Do not use an enabled password for a superuser account.
Contact vendor if assistance is needed. |
