Skip to main content
vraev
Staff
Staff
August 6, 2025

Technical Tip: Troubleshooting steps if the Remote Access feature to the FortiGate is not working

  • August 6, 2025
  • 3 replies
  • 3354 views
Description

 

This article describes basic troubleshooting steps to undertake when 'Remote Access' is not working from the FortiManager.

 

Scope

 

FortiManager v7.4.2 and above.

 

Solution

 

Connections diagram:

 

diagram.png

 

The following options are needed on the FortiManager side:

 

config system admin setting    set fgt-gui-proxy enable    set fgt-gui-proxy-port 8082 end  config system admin profile    edit "YourAdminProfile"      set fgt-gui-proxy enable    next end

 

They can also be configured in the GUI:

 

2025-08-07 11_45_12-FortiManager - weepy-fmg-esx47 - System Settings - Settings — Mozilla Firefox.png

 

And:

 

2025-08-07 11_38_28-FortiManager - weepy-fmg-esx47 - System Settings - Admin Profiles — Mozilla Fire.png

 

Additionally:

  • The remote access port (TCP 8082 by default) should be allowed on the way from the workstation to the FortiManager.
  • No deep inspection or other implicit SSL proxy should be on the way.
  • FGFM tunnel established and up between FortiManager and the FortiGate.
  • The FortiGate admin-server-cert (System -> Settings -> HTTPS server certificate) should not have expired.
  • If FortiGate has trusted hosts set, use the FortiManager FGFM tunnel IP (169.254.0.1) in the trustedhost list.

 

Note: The default ports and explanation about them can be found in Incoming ports.

 

Example of operation:

'Right-click' a FortiGate in Device Manager and select Remote access from the context menu:

 

2025-08-07 11_59_32-FortiManager - weepy-fmg-esx47 - Device Manager - Device & Groups - Table View —.png

 

This opens a new browser tab redirecting to the FortiManager address and FortiGate GUI proxy port:

 

2025-08-07 12_01_16-Mozilla Firefox.png

 

Note: Some browsers may restrict the pop-up redirect. Make sure to allow it in the browser settings if needed.

 

Command to run on FortiManager and FortiGate.

 

diagnose sniffer packet any "port 8082" 4

 

Note:

  • After upgrading FortiManager to v7.6.5, the Remote Access fails with '502 Bad Gateway error' when trying to access a FortiGate set to use non-standard admin-sport (the default is 443). This is a Known Issue (number 1240231) that was solved on FortiManager v7.6.6.

 

proxyerror.png

 

  • GUI remote access is not supported on FortiManager Cloud. However, remote access to FortiGate using SSH is supported.
  • For more details about the limitations of FortiManager Cloud, refer to Limitations of FortiManager Cloud.

 

Related document: 

Remote access to FortiOS GUI from FortiManager 7.4.2

3 replies

CriticalFailure
Visitor III
June 15, 2026

Currently experiencing 502 proxy error with FGM on 7.6.7 + FortiOS on 7.6.7. No solutions in the article resolve the issue. 

MauriceLeon
Visitor III
June 16, 2026

Same problem with 7.6.7 FMG and FortiOS….

Known issues | FortiManager 7.6.7 | Fortinet Document Library

Still under known issues:

1300206

Under Device Manager, "Remote Access" to managed FortiGate devices running FortiOS 7.6.7 may fail and display a "Proxy Error" message in the GUI.

CriticalFailure
Visitor III
June 16, 2026

Good catch. Thanks.

Thought Leadership Security Summit. Outpace New Threats with AI - enhanced defense. Tuesday, Septmeber 15, 8:30 AM - 2:30 PM PT. The Golf Club at Newcastle, WA.
Virtual event | September 2026. SASE summit. The age of autonomous trust. Register here!