Technical Tip: Blocking email messages with empty or blank senders
Description
This article describes that in some cases, a blank sender may mean that the email is spam. There are two places where the sender can be blank. One is in the envelope and the other is in the From field in the data section of the email.
The following article explains the process of configuring the FortiMail so that blank senders/domains are blocked.
The following article explains the process of configuring the FortiMail so that blank senders/domains are blocked.
Scope
FortiMail.
Solution
Blocking an Empty Sender in the Envelope
Profile -> Session -> Edit the inbound session profile -> Unauthenticated Session Settings, Select 'Reject empty domains', and then OK.
Blocking an Empty Sender in the From field in the Data section
Profile -> Session -> Edit the inbound session profile -> Unauthenticated Session Settings, Select 'Reject empty domains', and then OK.
Blocking an Empty Sender in the From field in the Data section
- Go to Profile -> Dictionary.
- Create a new dictionary with the following 2 regex expressions:
^From: $
^From:$
Ensure that:
- Enable pattern maximum weight limit.
- Search header.
- Search body.
- Select 'Create'.

- Go to Profile -> AntiSpam and edit the antispam policy in use.
- Select Dictionary -> With dictionary profile: and select the Dictionary that has just been created.
- Select OK.

This will prevent emails with empty senders/domains from getting to users.
