Troubleshooting Tip: Special characters are not allowed in certificate name
| Description | This article describes an issue where, when creating or importing a certificate on FortiAnalyzer, FortiManager, the following validation error may appear:
Certificate name can only include letters, numbers, '-', '_', and space |
| Scope | FortiAnalyzer, FortiManager. |
| Solution | When creating or importing a certificate containing special characters in its name such as "@#%&/\!*()." on a FortiManager, FortiAnalyzer, the following error will appear:
Certificate name can only include letters, numbers, '-', '_', and space
This occurs when the certificate name contains unsupported characters other than letters, numbers, hyphen '-', underscore '_', space. e.g 'test@test.com'.
To resolve this issue:
In certain cases, a certificate already installed on FortiAnalyzer or FortiManager may contain special characters in its name carried over from older firmware versions, which are lost during a firmware upgrade. During the upgrade process, the following message may appear in the console logs.
In order to overcome this situation, follow the steps outlined below:
config system certificate local show
Note that a '-651' error may still appear in the console for the old certificate if still present before upgrade on the device; however, the new certificate will function as expected. |

