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jstan
Staff
Staff
April 12, 2019

Troubleshooting Tip: False positive power supply and temperature alerts on FortiGate

  • April 12, 2019
  • 0 replies
  • 40705 views

Description

 

This article describes scenarios where false positive power supply failure and temperature error logs may be generated on the FortiGate.

 

Scope

 

  • FortiGate-6xF.
  • FortiGate-8xF/FortiWiFi-8xF.

  • FortiGate-9xE.

  • FortiGate-10xE.

  • FortiGate-20xE.

  • FortiGate-14xE.

 

Solution

 

On FortiGate models without a redundant power supply (RPS), the following log may appear even though the device has only a single PSU:

 

Example:

 

date=2022-10-25 time=09:57:16 eventtime=1666663036625727500 tz="+0800" logid="0100022105" type="event" subtype="system" level="critical" vd="root" logdesc="Power supply failed" action="ipmc-sensor-monitor" status="failure" msg="PSU [2] not detected" 

This is an known issue and fixed in 7.0.11 onwards, 7.2.5 onwards, 7.4.0 onwards 

 

 

Root cause:

This is a known issue where the system incorrectly expects a second PSU and reports it as failed.

 

Fix status:

The issue is resolved in the following FortiOS versions:

  • v7.0.11 and later.

  • v7.2.5 and later.

  • v7.4.0 and later.

 

Note: It is recommended to reach out to Fortinet support, as there could be problems with the unit. Include the output of the following commands when opening a ticket with Fortinet support TAC: 

 

Diagnostic commands:

Note: Several legacy commands have been deprecated or removed in newer FortiOS releases starting from v7.2 and above.

 

execute sensor list
execute sensor info
execute sensor detail

diagnose hardware deviceinfo psu

diagnose hardware ipmitool mc info
diagnose hardware ipmitool sensor

 

Use the commands below instead.

 

get system status 
diagnose alertconsole list
 
diagnose test application ipmc_sensord 1 
diagnose test application ipmc_sensord 2 
diagnose test application ipmc_sensord 4 

diagnose test application ipmc_sensord 5
diagnose test application ipmc_sensord 6
diagnose test application ipmc_sensord 7

 

Debug logs:

 

diagnose debug disable

diagnose debug reset

diagnose debug application ipmc -1 

diagnose debug enable 

 

To stop the debugging: 

 

diagnose debug application ipmc 0 

diagnose debug disable

diagnose debug reset 

 

Recommended action:

If the unit does not support RPS, the log can be safely ignored. Upgrade FortiOS to a fixed version if possible.

 

Reset the power supply. If it is designed for hot-swapping, perform the reset while the power remains ON. If it is not hot-swappable, turn off the unit before resetting the power supply. Replace the power cord and verify the wall outlet. Observe the LED to see if it lights up green.

 

If the LED remains red, gather the output using the commands mentioned earlier and submit a ticket through FortiCare. For more information, see this article: Customer Service Tip: How to create a ticket for Fortinet TAC.

  

False positive temperature failure on FortiGate-8xF/FortiWIFI-8xF/FortiGate-9xE/FortiGate-10xE/FortiGate-20xE/FortiGate-14xE: 

 

date=2023-04-26 time=09:26:16 eventtime=1682493976021401930 tz="+0200" logid="0100022109" type="event" subtype="system" level="warning" vd="root" logdesc="Temperature too high" action="ipmc-sensor-monitor" status="failure" msg="TMP 4 Temperature is too high: 32000.00 (75.0 celsius degree)" 

 

The logs above could be related to a known issue regarding wrong temperature calculation in a sensor list on FortiGate-8xF/FortiWIFI-8xF/FortiGate-9xE/FortiGate-10xE/FortiGate-20xE/FortiGate-14xE.

 

This is resolved in v7.0.13 onwards, v7.2.6 onwards, and v7.4.1 onwards.

 

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