Skip to main content
Staff
March 18, 2026

Technical Tip: Workaround for '500 Internal Server Error' encountered during self-registration with SMS following upgrade to v6.6.6, v8.0.1

  • March 18, 2026
  • 0 replies
  • 201 views
Description This article describes how to work around the 500 Internal Server Error returned during self-registration with SMS in the self-service portal after upgrading to version 6.6.6 or 8.0.1.
Scope FortiAuthenticator v6.6.6, v8.0.1.
Solution

In the affected firmware versions, if a guest user attempts to register through a self-service portal hosted on FortiAuthenticator using SMS as the activation method, 500 Internal Server Error is returned during registration.

 

From the https://<FAC-IP>/debug  -> Log Categories -> Web Server -> Apache logs:

 

2026-01-22 08:53:07,928 error django.request log 1771 140712689866432 Internal Server Error: /portal/register/
................................................................
[Thu Jan 22 08:53:07.929986 2026] [wsgi:error] [pid 1771:tid 2029] [remote 127.0.0.1:44834] File "/lib/python3.13/site-packages/django/db/models/query.py", line 637, in get
[Thu Jan 22 08:53:07.929989 2026] [wsgi:error] [pid 1771:tid 2029] [remote 127.0.0.1:44834] raise self.model.DoesNotExist(
[Thu Jan 22 08:53:07.929991 2026] [wsgi:error] [pid 1771:tid 2029] [remote 127.0.0.1:44834] "%s matching query does not exist." % self.model._meta.object_name
data.apps.customviews.models.PortalTemplate.DoesNotExist: PortalTemplate matching query does not exist.

 

Workaround: Use the email method instead of SMS.

 

Note:

Resolved issues 6.6.8 : 1209416: 500 internal server error during user self-registration with the SMS in the self-service portal.

Known issues 8.0.1 

Resolved issues 6.6.7 

Thought Leadership Security Summit. Outpace New Threats with AI - enhanced defense. Tuesday, Septmeber 15, 8:30 AM - 2:30 PM PT. The Golf Club at Newcastle, WA.
Virtual event | September 2026. SASE summit. The age of autonomous trust. Register here!