Technical Tip: Workaround for '500 Internal Server Error' encountered during self-registration with SMS following upgrade to v6.6.6, v8.0.1
| Description | This article describes how to work around the 500 Internal Server Error returned during self-registration with SMS in the self-service portal after upgrading to version 6.6.6 or 8.0.1. |
| Scope | FortiAuthenticator v6.6.6, v8.0.1. |
| Solution | In the affected firmware versions, if a guest user attempts to register through a self-service portal hosted on FortiAuthenticator using SMS as the activation method, 500 Internal Server Error is returned during registration.
From the https://<FAC-IP>/debug -> Log Categories -> Web Server -> Apache logs:
2026-01-22 08:53:07,928 error django.request log 1771 140712689866432 Internal Server Error: /portal/register/
Workaround: Use the email method instead of SMS.
Note: Resolved issues 6.6.8 : 1209416: 500 internal server error during user self-registration with the SMS in the self-service portal. |
