Skip to main content
rbraha
Staff
Staff
January 14, 2026

Technical Tip: Restricted administrators on FortiAuthenticator cannot manage tokens after the upgrade

  • January 14, 2026
  • 0 replies
  • 236 views

Description

This article describes an issue encountered when upgrading to FortiAuthenticator v8.0.

Scope

FortiAuthenticator.

Solution

Restricted Admin functionality worked as expected before the upgrade, based on the FortiAuthenticator admin profile integration guide, Admin Profiles.

The pre-upgrade admin profile test1 on FortiAuthenticator had the following permissions configured:

Figure 1. Permission sets:

Figure 1. Permission sets


After upgrading to FortiAuthenticator v8.0, the following error has been observed when trying to assign a token to users.

Figure 2. Error assigning token:


Figure 2. Error assigning token

 

Even with full read-write permissions assigned to this admin profile, the behavior remains unchanged.

Note: For custom 'User and Device' profile make sure custom profile must have read-write permission and in permission set 'can view FortiToken' is included in order to view the Tokens.


Custom profile:

8d520a3b.jpg


Permission set:

82111c9c.jpg


Solution:

This is a known issue tracked under engineering ticket 1224409: Restricted admins cannot manage tokens after upgrade. Known issues (FortiAuthenticator v8.0.1).


This issue is resolved in version 8.0.2: Release notes.

    Thought Leadership Security Summit. Outpace New Threats with AI - enhanced defense. Tuesday, Septmeber 15, 8:30 AM - 2:30 PM PT. The Golf Club at Newcastle, WA.
    Virtual event | September 2026. SASE summit. The age of autonomous trust. Register here!